SolidWorks/Photoworks Question!

Ok, so I feel like this may be a ridiculous question, but right now I am completely baffled.

How do you access the PhotoWorks toolbar in Solidworks. I have turned the add-on on, and am able to to access the materiels/decals/scenes/lights in the Task Pane, and in the Feature Management Tree, but nothing for Photoworks shows up in Toolbar area.

I used Solidworks/PhotoWorks through internship over the summer, and never had this problem, the tool bar always was just there. This is my first time using the program which is loaded on our computers at school, so I don’t know what the deal is. I have checked multiple computers, and it is not showing up on any of them.

Does anyone know what the problem is here?
All I wanted to do was get some quick rendering done this morning

:angry:

Please someone help!

With PW ‘active’ in the add-ins menu, go to View → Toolbars → Photoworks… maybe that’ll work?

Georgeous, Thanks for the response, but nope it doesn’t work. That is partly why I am a little baffled about it, because it doesn’t even give it as an option under the Toolbar menu.

Yeah, I had a feeling my obvious solution wouldn’t suffice. Sorry!

Maybe it is somehow hidden under another tool bar…? Maybe uncheck all the visible toolbars until there is nothing left… you’ve rebooted as well right? Weird.

Yeah, I have rebooted, moved and opened the program on each and every computer in the lab… and still no luck. I don’t know if something got loaded wrong, but it is strange for there to only be PhotoWorks missing from the Toolbar menu…

Check the directory for Photoworks C:\Program Files\SolidWorks\photoworks and see if anything weird is going on in there… you should have a TLB file, a DLL file and the PW Image viewer as well as the data and lang folders. It sounds like you are missing some sort of executable file or something.

C:\Program Fils\SolidWorks\photoworks

Contents:

Data (folder)
Lang (folder)
Imf_disp (Photoworks Image Viewer)
P.works.dll
Photoworks (TLB File)

Everything seems to be there, could there be an issue with this being an education licensed copy? I would assume not, but… Im stumped

I know this is getting a little sad and specific, but is the dll file actually called

p.works.dll (emphasis on the first dot)

or

pworks.dll

It should be the latter. I’ve have troubles with Photoshop before which the dll files.

Also, just check the Plug-Ins folder in the solidworks directory and check that ifxrendering.dll is in there.

it is Pworks.dll I don’t know where I got the extra dot.


In the Plug-ins folder

ifxrendering.dll
ifxexporting.dll
ifximporting.dll
ifxscheduling.dll


georgeous i apprieciate the help!

I’'m afraid I can’t think of anything else it could be. It’s a really weird thing to happen. Maybe send Solidworks a quick email asking them about it, which I know won’t do you any good for the time being. Sorry couldn’t help more.

On a leaving note… aren’t computers great!

Well thanks for your help!


Anyone else have any ideas?


-Katie

dont bother with Photoworks. its such a memory hog. try using flamingo or 3dmax.

would love to, but don’t have the money…

I would reinstall SolidWorks. Make sure PhotoWorks gets installed and go from there. If that doesn’t work I would contact SolidWorks.

the problem is with the software that is installed on the computers in one of our labs at my University. I have contacted the person in charge of it, and they said “they are working on it.” But you know what that means…

I ended up just buying the education edition of it a week or so ago, only $90, can’t go wrong.

hi

in our school we had the same problem and after a few days i succeeded in solving this.
First login as administrator and go to the folder of SolidWorks where you have to give full access to all users for the folders that Photoworks uses
(i give full access to all folders accept to templates, and certain libraries)
then start SolidWorks and load the add-in photoworks. Then you will see that the toolbars are visible.
Then logout and login as a normal user. When you start solidworks and after that photoworks you will see that it is solved.
So for me the key problem was that i didn’t run photoworks as administrator(what the reason for this bug is i don’t understand, some computers worked good and some refused…

hello im having the exact same problem, but i have bought this student copy but i still can find photo works anywhere still. i dont really understand the post above but it seems like a solution. please plase please!! i need a solution quice as its driving me crazy!!!