HELP! Alias 2011 downgrading catastrophe!

I recently tried Alias 2011, but due to severe bugs I was forced to downgrade to 2010.

But since Alias 2011 doesn’t come with an uninstaller all I could do was trash the application (OS X).

This seems to have messed up something in 2010 because whenever I try to open an .IGS file, it tells me that “directconnect” is not installed.

Before I installed Alias 2011 I did not get this error!

Alias 2010 does come with an uninstaller, but ever since I trashed 2011, the uninstaller claims that nothing is installed, even though I tested to re-install Alias 2010 once just to see what happens!

Working with .IGS files is extremely important to me, and I have a deadline coming soon, so if anyone has any tips to help quicky, please let me know!

Thank you!
2.jpg
1.jpg

Understand the frustration - had a similar issue with some Adobe ‘residue’.

Try this App - http://www.appzapper.com/

If you have an element (file) of the 2011 install, drag it onto the AppZapper app and it will find all associated files (all of 'em) and trash the lot. That should remove any of the leftover files that may be causing you problems.

Then, you can reinstall 2010 from scratch.

Should work for you.

-David

Thank you for the tip, unfortunately it did not make any difference.

I used CleanApp instead of AppZapper, since AppZapper hasn’t been updated in a very long time, and CleanApp has a nice community feature which enables you to see what files other users have found and delete them as well.

But since it was a no-go, I decided to dig around after the package receipt as see if I could get any information from the bill of materials that should be posted in /Library/Receipts. Imagine my surprise when there was none, except for the bloody uninstaller.

Back to square one. :frowning:

EDIT: I enabled one of CleanApps other features which is installer logging, and it showed that Alias drops its receipts in /private/var/db/receipts where actually most other receipts are stored as well, so my mistake on that one.

More interestingly, though, is that it does install something to /Library/Application Support/Autodesk/DirectConnect/4.0/

This is news to me, and I bet it’s news to people who were told that you can delete it just by dragging the application icon to the trash as well.

I haven’t been able to solve my issue yet, but this is definitely a clue I can use.

EDIT: Hmm… my Alias 2010 installer only seem to install documentation for DirectConnect, not the actual thing itself. However, Alias 2011 did install the entire thing, as shown by com.autodesk.pkg.AutodeskDirectConnect5.0.bom (which includes a lot of bin and dynlib files).

Not positive on the Mac side, but there’s no application listed indepenantly for direct connect?

On Windows Direct connect, documentation and Alias itself are 3 different installed programs.

Even when you reinstalled 2010 it still failed?

I found a link on Autodesks site for the 2010 R1 installer for Mac, see if it lets you install this independently.

http://images.autodesk.com/adsk/files/autodesk_directconnect_2010_r1_english_osx.dmg

No, Alias 2010 for Mac does not disclose that it is installing DirectConnect 4.0, it does seem to uninstall it though (since it’s absolutely gone from my system).

Alias 2011 doesn’t disclose that it’s installing DirectConnect 5.0, and any user who trashes the application gets left with it in the Library.

Thank you for the link, it’s greatly appreciated, and it provided me with what I guess is the final clue as to why I don’t have it. The question now is, why didn’t the Alias 2010 installer let me know this? And the second question is of course… aarrrrggghhhhhh

Time to get my Time Machine backup of the old installation and hope it’s there.

EDIT: WAIT A MINUTE… there is still one question unanswered: I did not uninstall Alias 2010 until I began experiencing the troubles with the dialog box telling me that DirectConnect wasn’t installed… so what messed it up in the first place? Seems to me that either DirectConnect 5.0 or Alias 2011 is the culprit and interferes with the old DirectConnct 4.0 somehow…

EDIT: Alias 2011 DOES disclose that it’s installing DirectConnect. My mistake. I just checked. It doesn’t disclose the new license manager, though, which it installs into /Library/Frameworks/ADLM.framework amongst a few other places (it does place files across various private and system folders more than 2010 which was quite tidy).
3.jpg

But if you have timemachine, cant you just reverse the system to before you tried installing 2011?
Been trying to get things to work with alias lately, but hotkeys and shelves doesnt work to my liking so I surrendered and went to rhino.


Lycka till!

Yup, Time Machine to the rescue. I have DirectConnect 4.0 back now.

Amazing that 2010 isn’t fully Snow Leopard compatible.