Coroflot Page settings

How do I set my coroflot page to be able to be viewed by people in this site but not come up on a regular Google search? Is this possible? Any info you can give would be greatly appreciated.

Did you already try picking the “Make my portfolio accessible only via my personal URL” under the Edit Profile options? Not sure if this is exactly what you’re looking for, but it will definitely limit your portfolios search exposure.