Alias to Rhino for rendering (Help needed!!!)

For time sake, I am rendering my Alias model in Rhino.

I exported the file as both step and as igs and it opened in Rhino fine. However as I shaded the model, the mesh seems to be messed up. The same thing appears in the test run render. Here are the screen shots:

There shouldn’t be anything wrong with my model as it appears fine in wire frame. I tried to change the Rhino mesh setting to higher but it doesn’t help at all, and got worse. So what can I do to get rid of it? I cannot photoshop it later because this is a transparent part.

Hard to tell what’s going on. Looks like the slope is not meeting the outside lip very well. Have you tried posting the 3DM file on the Rhino Support Newsgroup?


What I meant is those surfaces in the rendering with the red arrows aren’t supposed to be there. If you look at the wireframe, they do not exist, but somehow appears on the rendering.

This has happened to me a bunch of times, I don’t know specifically whats going on but those surfaces you are seeing (the ones that shouldn’t be there) are “linked” to some other surface or surfaces in the model. It depends on how you built the surface in alias. To find out which surface is messed up try clicking on those unwanted surfaces while your model is shaded, it should select the bad surface, to be sure, delete that and your unwanted should go away. Its a really annoying problem in rhino but what I usually do is simply rebuild the surface using a different operation the second time around.


dont know Step. guessing Rhino trying to triangulate iges for rendering. try exporting out of Alias in polymesh format. not sure what Alias exports now. or what Rhino imports. SDL is a polymesh. related to STL. or could export out an OBJ. Alias should export and Rhino should import. i use OBJ all the time with Pro/E.

You might want to try a couple of workarounds:

  • stitch the part in studio, and hopefully the tessellation will be better when you export the iges file

  • select the surface in studio and tessellate them before you export them, so you are rendering a polyset

  • insert some spans in the studio model before exporting, as this can sometimes help with single-span trimmed surfaces

  • if all else fails, try rendering in ImageStudio. You can probably get a good rendering out in about an hour, and you can get a free download here:

Here is what I think might work.
Both Alias and Rhino model spheres the same way - as square surfaces with two sides having a length of 0. Imagine a bedsheet bent into a sphere; you’ll have a meeting point of two edges, while the other two edges are wrapped tightly around the north and south poles - essentially a zero length edge. If you want to see this meeting point in Rhino, create a sphere and set the isoparms to zero. All you’ll see is a single curved line where the surfaces meett. As you can imaging, this is really bad, as both programs want squares with edges of some length other than zero.

I would untrim the sphere in Alias and perform this little trick (assuming you haven’t already). Create a circle with a very small radius, say .1mm. Now place this circle over the north pole, and project it along the axis until it reaches the south pole. Now trim away the tiny circles on the surfaces. What this does is create two edges of a length equal to the circumference of the .1mm circle - enough to give the surfaces 4 sides of a length greater than zero. See if that cures the problem.

an old ‘bug’ in rhino.
I had the same problem… wrote for support on the newsgroup (
This is what I got:
“It is most likely the render mesh ‘leaking’ out… try this: ExtractSrf
the fillet and the adjacent surfaces and Untrim which ever is howing the
spike. Use Keep=Yes in untrim. Now, reTrim the surface if it needs it.
Is tat better?”

I have yet to try this since it hasn’t happened since… but tell me if it works

This looks like a tesselation problem of a trimmed surface. Setting higher tesselation resolution might help. Or dividing the trimmed surface(s) via the Trim Divide tool in Studio.

BTW you might be better of investing a tiny bit of time trying to render in Studio (or ImageStudio like someone else suggested) rather than using the Rhino rendering engine, unless you’re using Flamingo but even still. Just my 2 cents…

Good luck.

Ok I resolved the problem.

Basically, I found out which surfaces were problematic and deleted them.
Then I went back to Alias and export only those surfaces and import them into Rhino, using igs. Now it works.

The common characteristic with those surfaces is that they are “revolved” surfaces. So this probably has got to do with the “sphere” problem mentioned. However, this isn’t the first time I’ve encountered this. Once I was building a surface in Rhino, trimmed it, but it won’t trim clean.

The main reason why I am using Rhino instead of Alias is I have not learnt much about rendering in Alias yet. I was trying to get the material and lights right in flamingo because I was trying to bring out certain VERY subtle characteristics on my model. It took me 6 hours of twicking of lights position, intensity, shadow hardness, material( transparent plastic, glass, transparent auto paint) and the various properties that can be adjusted. I finally got it. I can’t imagine doing this in Alias, unless I have a whole week to do it.

I am running a rendering now as I type. I will post some screen shots to show you guys what I mean by “subtle” characteristics.

Thanks a million for your help!!!

Although you have fixed the problem, I think Redwing had a really good workaround. Another method I have found is to just Detach the revolved surfaces so the beginning and end aren’t at the same point – you basically cut the sphere in half so you’re dealing with hemispheres instead.

You’re comment about rendering in Alias is pretty valid, you need some time to get it to look right, but when you do they look great.

I don’t want to preach, but in ImageStudio, the Environment/Lighting/Material set-up is already done, you just have to make the fine adjustments to get it looking the way you want. Somthing that would have taken me day in Alias, now only takes a couple of hours in ImageStudio2.0.