AI corrupt

Sorry I know this isn’t a troubleshooting forum, but im really stuck.
I saved an AI CS2 file on a flash stick. I properly ejected it and then brought it home and replaced the old file on my home station.
A few days later I try to open the file and it just shuts down AI without any warning. I take it my file is corrupt. and its a huge important file. I have googled my ass off with no luck in fixing the file. (all the other files on the flash disk still work)

I had it layed out in 1 layer with all my pages spread out across the board, so when i open with acrobat it only shows the work within the print area.

Has anyone been in this spot with AI? If so, any advice or help is greatly appreciated!!!

thanks :cry:

The preview thumbnail also works when im in the “open” dialog box

The acrobat part isn’t a glitch, it only opens up what’s in the artboard. AiCS2 is glitchy, I haven’t seen that one before. If you just need the image you can try opening it in photoshop but it may make a huge file. I believe in psd they now let you import the vector objects and they’ll remain editable. Then you can try to resave it so that illustrator can open it. Also sometimes just renaming a file in the finder makes some things open that didn’t previously. Good luck.

I’ve had that happen before (I have CS2 as well)

If you have a mac, try opening the file in mac preview, you can then export it as a pdf, then try opening that in illustrator… it’s worked for me.

Thank you both for your input.
Skinny - that was the problem, only the art board area was showing up, i have stuff all over the document…

YO - great idea! i dont have a mac, but sent the file to a friend who is a mac user, and it worked great!!! I cant tell you how much this has helped me out. Many thanks! beers on me…

no problem dude, glad it worked! … Sorry to say I’ve also been on that pain train!